Try to install slim-image-resize

this is the link:

my slim:
“slim/slim”: “^3.0@RC”,

and when i try to install i get that error:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for tuupola/slim-image-resize ^0.6.1 -> satisfiable by tuupola/slim-image-resize[0.6.1].
- tuupola/slim-image-resize 0.6.1 requires slim/slim ~2.3 -> satisfiable by slim/slim[2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.5.0, 2.6.0, 2.6.1, 2.6.2, 2.x-dev] but these conflict with your requirements or minimum-stability.

Installation failed, reverting ./composer.json to its original content.

sombody know how to fix that?

Hi,

your slim is : “slim/slim”: “^3.0@RC”

slim-image-resize 0.6.1 requires slim/slim ~2.3

The meaning of ~ in composer is explained here >>

and here >>

https://getcomposer.org/doc/articles/versions.md#tilde

Give a try with Slim >> ~2.3

but its works with slim 3?

i try and the same msg i get

Hi,

As per documentation it will not work with slim 3.X

tuupola/slim-image-resize requires :

  • slim/slim: ~2.3
  • intervention/image: ~2.0

source >> https://packagist.org/packages/tuupola/slim-image-resize

You may raise an issue here : >> https://github.com/tuupola/slim-image-resize/issues

u can help me what to do
i need a crop image like that packag
maybe you meet other packag or somthing?

You might want to have a look at other packages like Intervention/image.