Fresh installation composer error

On a new fresh installation with composer on a host with already slim installed 
when issue : composer require slim/psr7
I have this error
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires slim/psr7 ^1.6 -> satisfiable by slim/psr7[1.6, 1.6.1].
    - slim/psr7[1.6, ..., 1.6.1] require psr/http-message ^1.0 -> found psr/http-message[1.0, 1.0.1, 1.1] but the package is fixed to 2.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.

and installation fail