Error installing php-di on slim 4.8

error that appears.

Problem 1
- php-di/php-di[6.3.0, …, 6.3.3] require psr/container ^1.0 → found psr/container[1.0.0, 1.1.0, 1.1.1] but the package is fixed to 2.0.1 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- Root composer.json requires php-di/php-di ^6.3 → satisfiable by php-di/php-di[6.3.0, 6.3.1, 6.3.2, 6.3.3].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

thanks it worked correctly for me