Slim / Composer is checking wrong version of php


I 'm trying to install Slim 3 by composer, but the composer returns error in the version of PHP:

  • slim/slim 3.5.0 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.

My PHP version is 5.6.18 .

PHP Version 5.6.18

Where the composer checks the version ?


Doesn’t sound like your server is setup correctly.

composer uses the php command on the CLI… it’s possible you have php56 installed in which case composer is not going to work.

What does php -v say?

I entered in contact with de support of server and the server configuration is correct now.